VPN - RDP Shortcut Feature - Delayed Typing

I recently discovered that the RDP Shortcut feature was causing delayed typing.

The problem is that if you have a Basic VPN to the computer sites that can see the Pool Host Servers it will route the packets over the VPN instead of through the public network.

Since Basic VPN is 100mbps the VPN pipe can get full quickly when someone prints to a printer onsite, which is causes the typing delays.

I have added NSG firewall rules to block UDP 3390 inbound and outbound  from coming from the sites to correct this.

My RTT has dropped from 40ms to 9ms on the connections under "User Session" in the NMM console, and the typing delays have since gone away.. 😉

1

Comments (3 comments)

Avatar
Dave Stephenson

Great find and workaround!

I'm curious if you're using RDP Shortpath or RDP Shortpath for Public Networks?

0
Avatar
Moses Hull

Enable RDP Shortpath for Public Networks.

1
Avatar
Dave Stephenson

Interesting. I would think that "public networks" would mean it would not try to go over any VPN tunnels/Express Routes.
It's good to know that adding a simple NSG rule can fix this issue.🙂

0

Please sign in to leave a comment.